top

Boost solenoid

Post new topic Reply to topic trackscotland.co.uk Forum Index | Technical    Page 1 of 1

Thu Jan 25, 2018 1:04 pm PostPost subject: Boost solenoid
Wull
user


Joined: 19 Jul 2013
Posts: 265
Location: Killin

Reply with quote

I bench tested the 3 port boost solenoid today and it clicks when voltage is applied, I can blow through the ports and when voltage is applied the solenoid closes and I can no longer blow air through.

Now has anyone ever experienced a faulty bcs that worked when bench tested but couldn't work properly on the vehicle, e.g can't control the boost other than fully open or fully closed.

I had ordered a replacement one but cancelled the order after doing the test, I'm now thinking I've been a bit hasty and should have waited for it to arrive, fitted it and then seen if it made any difference. If not I could have sold it on.

Any ideas? Anyone got a 3 port they could send to me just to test and I can send it back.
_________________
ND spec'd Evo 8
Impreza bug sti track car
Wagon SL ppp
Back to top
View user's profile Send private message
 
Wed Jan 31, 2018 1:14 pm PostPost subject:
Steviej
user


Joined: 23 Jan 2014
Posts: 134
Location: Elgin

Reply with quote

Tested one I have out of curiosity, it seems to reverse the ports when powered up, ie if you can blow through one with no power, but not the other and vice versa when powered up 12volts
Back to top
View user's profile Send private message
 
Wed Jan 31, 2018 9:53 pm PostPost subject:
Wull
user


Joined: 19 Jul 2013
Posts: 265
Location: Killin

Reply with quote

Steviej wrote:
Tested one I have out of curiosity, it seems to reverse the ports when powered up, ie if you can blow through one with no power, but not the other and vice versa when powered up 12volts


Yeah you can blow through port 2 & 3 and vice versa, once 12v is applied it no longer goes through port 3 but will be bled through port 1.

I think what's happened with mine is it'll work when 12v is applied but when the ecu applies smaller amounts of volts for smaller amounts of wastegate duty then it doesn't work.

I've fitted the new one now so I'm now waiting to see if it's worked, I'll hold off until the mapper has everything hooked up and hopefully the boost will be over 1 bar.

Here's another thing though, do you need a resteictor pill when you have a 3 port boost solenoid fitted and have it mapped?

I checked mine tonight and there is no restrictor pill fitted, I think it's suppose to be in the line that goes from the turbo to the solenoid.
_________________
ND spec'd Evo 8
Impreza bug sti track car
Wagon SL ppp
Back to top
View user's profile Send private message
 
Thu Feb 01, 2018 1:28 pm PostPost subject:
Steviej
user


Joined: 23 Jan 2014
Posts: 134
Location: Elgin

Reply with quote

Normally do away with the std solenoid and pipes when fitting the 3 port, so no pill required as far as Iím aware
Back to top
View user's profile Send private message
 
Post new topic Reply to topic trackscotland.co.uk Forum Index | Technical    Page 1 of 1

View previous topic
View next topic
Display posts from previous:   




You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum